Phiên bản thử nghiệm của trình duyệt nổi tiếng Firefox quả thực rất tuyệt vời, nhiều cải tiến về giao diện và khả năng vận hành, các thẻ mở luôn ở vị trí on-top, hệ thống menu với 1 chút gì đó của Opera… tất cả đều tuyệt vời (theo ý kiến đánh giá của cộng đồng sử dụng) cho tới khi mọi người cố gắng cài đặt và sử dụng lại các add-on hỗ trợ. Bài viết sẽ giới thiệu với các bạn mẹo để sử dụng các add-on trên phiên bản Firefox 4.0 beta.

Đường dẫn tải Firefox beta tại đây.

Khi cố gắng cài đặt add-on thì chúng ta sẽ gặp lỗi thông báo không tương thích sau:

Cách khắc phục: mở 1 thẻ mới và gõ about:config, sau đó kích chuột phải vào bất kỳ vị trí nào và chọn tiếp New -> Boolean:

Menu popup sẽ hiện ra, tùy thuộc vào phiên bản beta đang sử dụng thì bạn tạo 1 trong 2 giá trị preference tương ứng sau:

4.0 Beta: extensions.checkCompatibility.4.0b

4.0 Release: extensions.checkCompatibility.4.0

Sau đó thiết lập giá trị về false:

Và sau đó thì mọi việc đã trở nên đơn giản hơn rất nhiều, và chỉ việc cài đặt add-on như bình thường:

Chúc các bạn thành công!

(Theo Quantrimang)